home / help / Email

System Requirements

These are the system requirements to install and use WinZip:

  • Operating system: Windows XP, Windows Vista, Windows 7, Windows 8, or Windows 10.
  • Internet Explorer 8 or later.
  • Microsoft .Net Framework 3.5 or later
  • In order to use the WinZip Ribbon interface, Windows Vista with Service Pack 2 or a later operating system is required. Also, if using Windows Vista, the Platform Updates for Windows Vista is required. The Platform Updates for Windows Vista are part of the Windows Updates available for Windows Vista from Microsoft.

No other programs are required to add or extract files from Zip files. You can also create self-extracting Zip files with WinZip Self-Extractor Personal Edition, included with WinZip. However, if you need advanced self-extracting Zip file capabilities (such as the ability to create installation self-extracting Zip files) you may be interested in WinZip Self-Extractor, a companion product, which includes features tailored for software distribution and the ability to create a single self-extracting Zip file that can be run under Windows.