End of Support for older WinZip application versions

Support has ended for the following:

  1. WinZip 9.0 through WinZip 18.5
  2. WinZip Companion (Courier) 1.0 through Courier 4.5
  3. WinZip 1.0 through WinZip 2.0 for Mac
  4. WinZip Self-Extractor 2.2 through Self-Extractor 3.1

To view end of support dates for WinZip application versions newer than those listed above, please see the WinZip Knowledge Base.

The following will no longer be provided for unsupported versions of WinZip applications:

  1. Physical media shipments
  2. Product updates (including changes for bug fixes or new security threats)

WinZip Computing recommends that all users of unsupported WinZip versions upgrade to the latest release version assuming that their computer meets the current system requirements. Upgrading will allow you to receive the advantages of up-to-date security changes, new features, bug fixes, and technical support.

Registered WinZip users are eligible to upgrade to the latest release version for 50% off the full retail price. For more information on version upgrades, visit the How do I upgrade to the latest version? knowledge base article.

Technical support and customer service will continue to be provided for expired versions to assist with product downloads, installation issues, registration issues, and various technical issues to the best of our ability. If you have any questions about this information, please email Technical Support.

Related Articles:
When does support end for WinZip applications?
How do I upgrade to the latest version?